My purpose for this blog is to share what I learn as I become a better developer. Sometimes I have thought of an idea for a post but haven't come up with enough content to finish the entire post. I had a feeling like a post needed to be a certain length before it would be worth posting. That idea doesn't completely mix with my purpose for the blog. Sometimes you don't learn things in a large post, sometimes its just a little nugget of knowledge that doesn't require a ton of explanation.
With that said, something I recently relearned is that mapping objects to other objects, especially with different property names is a bad idea. It leads to confusion when working with the code. It also creates more opportunities for bugs to exist. So if you need a property from one object to map to a property on another object, use the exact same name. And if you can just use the original object without mapping to another object, that is even better.